summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 39 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd256573b54d..8c4d5a45027f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,48 @@
-# Maintainer: Karol Babioch <karol@babioch.de>
+# Maintainer: tarball <bootctl@gmail.com>
+# Contributor: Karol Babioch <karol@babioch.de>
pkgname=flamethrower
-pkgver=0.10
+pkgver=0.11.0
pkgrel=1
-pkgdesc="DNS performance and functional testing utility"
-arch=('i686' 'x86_64')
-url="https://github.com/DNS-OARC/flamethrower"
-license=('APACHE')
-depends=('ldns' 'libuv')
-makedepends=('cmake')
-source=("git+https://github.com/DNS-OARC/flamethrower.git#tag=v$pkgver")
-sha256sums=('SKIP')
+pkgdesc='DNS performance and functional testing utility'
+arch=(i686 x86_64 aarch64)
+url='https://github.com/DNS-OARC/flamethrower'
+license=(Apache)
+depends=(ldns libuv gnutls libnghttp2)
+makedepends=(cmake)
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/DNS-OARC/flamethrower/archive/refs/tags/v$pkgver.tar.gz"
+ 'gcc12.patch'
+)
+sha256sums=('427f39d7e21e18e68b323a0b9b28260e7d0dedbb9d117b309bf550672fb3fb36'
+ 'a4f6d3969d0a6fc1ab27982100d6da87c051164f0ca24380bd34f97a58497f7e')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 <"$srcdir"/gcc12.patch
+}
build() {
- cd "${srcdir}/${pkgname}"
- # Fix a issue with CMake package name of ldns
- sed -i 's/libldns/ldns/' CMakeLists.txt
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ cmake -B build -S "$srcdir/$pkgname-$pkgver" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DDOH_ENABLE=ON
+
+ cmake --build build --target flame
}
package() {
- cd "${srcdir}/${pkgname}"
- install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm0644 man/flame.1 "$pkgdir/usr/share/man/man1/flame.1"
- cd build
- install -Dm0755 flame "$pkgdir/usr/bin/flame"
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 "$srcdir"/build/flame \
+ "$pkgdir/usr/bin/flame"
+
+ install -Dm644 "$srcdir"/build/libflamecore.a \
+ "$pkgdir/usr/lib/libflamecore.a"
+
+ install -Dm644 LICENSE \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm644 man/flame.1 \
+ "$pkgdir/usr/share/man/man1/flame.1"
}