summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a57707eeabf9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Port pkgbuild for aur4
+# Original pkgbuild is here: https://github.com/aur-archive/flaxpdf-git
+# manteiner: pekman
+# initial submission: 26/september/2015
+
+pkgname=flaxpdf-git
+pkgver=20152609
+pkgrel=1
+pkgdesc="A simple FLTK PDF viewer"
+arch=('i686' 'x86_64')
+url="https://github.com/clbr/flaxpdf"
+license=('GPL3')
+depends=('fltk' 'poppler' 'lzo')
+makedepends=('automake' 'autoconf' 'git')
+
+source=(git://github.com/clbr/flaxpdf.git)
+sha256sums=('SKIP')
+
+build() {
+ cd flaxpdf
+
+ mkdir -p config
+ touch config/config.rpath
+ ./autogen.sh
+
+ # ensure gcc because clang doesn't support OpenMP yet
+ CC=gcc CXX=g++ ./configure --prefix=/usr
+
+ make
+}
+
+package() {
+ cd flaxpdf
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: