summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b27ab3b2c00..e3a91aa3a786 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Tom Zander
pkgname=flowee
-pkgver=949d9c789
+pkgver=1.5.1
pkgrel=1
-pkgdesc="Flowee the Hub"
+pkgdesc="Flowee Bitcoin products"
arch=('x86_64')
url="https://flowee.org/"
license=('GPL')
@@ -12,7 +12,7 @@ makedepends=('boost' 'cmake')
provides=('flowee-hub')
backup=("etc/flowee/flowee.conf")
install=flowee.install
-source=("git+https://gitlab.com/FloweeTheHub/thehub.git#branch=2019.04"
+source=("git+https://gitlab.com/FloweeTheHub/thehub.git#branch=2019.05"
"flowee.logrotate"
"flowee.conf"
"logs.conf")
@@ -20,17 +20,12 @@ source=("git+https://gitlab.com/FloweeTheHub/thehub.git#branch=2019.04"
sha256sums=('SKIP'
"aff02b3312c88113fe7316152c15f1545233dc8c2062ee8c36d2dbcad4a9f5bf"
"bc14acf0d1b4064553756a1e81c0b943e842296f2a2af6442e480b846392e6bc"
- "3ec85358d1629a3d41e55710646be6b6a0cda322175779934439432615beba3c")
-
-pkgver() {
- cd "$srcdir/thehub"
- git rev-parse --short HEAD
-}
+ "1e74675c7e27837847d5ba0a72fb73ff52f919be5b6e0e630a07735336fe015a")
build() {
mkdir -p build
cd build
- cmake -Dmark_release=true -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub
+ cmake -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub
make -j1 univalue leveldb
make
}
@@ -50,4 +45,6 @@ package() {
install -Dm 664 "$srcdir/flowee.conf" -t "$pkgdir/etc/flowee"
install -Dm 664 "$srcdir/logs.conf" -t "$pkgdir/etc/flowee"
install -Dm 644 "$srcdir/thehub/support/thehub.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm 644 "$srcdir/thehub/support/indexer.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm 664 "$srcdir/thehub/support/indexer.conf" -t "$pkgdir/etc/flowee"
}