summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c3b439c56b4..abe9d5f78ce9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,32 @@
# Maintainer: Tom Zander
pkgname=flowee
-pkgver=2020.02.1
+pkgver=2020.03.1
pkgrel=1
pkgdesc="Flowee Bitcoin products"
arch=('x86_64')
url="https://flowee.org/"
license=('GPL')
depends=('boost-libs' 'libevent' 'openssl')
-makedepends=('boost' 'cmake' 'autoconf' 'automake' 'pkgconf')
+makedepends=('boost' 'cmake' 'pkgconf')
optdepends=('miniupnpc')
provides=('flowee-hub')
backup=("etc/flowee/flowee.conf")
install=flowee.install
-source=("https://gitlab.com/FloweeTheHub/thehub/-/archive/2020.02.1/thehub-$pkgver.tar.gz"
+source=("https://gitlab.com/FloweeTheHub/thehub/-/archive/$pkgver/thehub-$pkgver.tar.gz"
"flowee.logrotate"
"flowee.conf"
"logs.conf")
-sha256sums=("7038635181f490babd723d33864e8a07287b8569bdefe9db4130703599beae36"
+sha256sums=("59536821254db2b39d1596d721090e5214fb43a855ed2cad81d0ffb4bb2a4daa"
"aff02b3312c88113fe7316152c15f1545233dc8c2062ee8c36d2dbcad4a9f5bf"
"bc14acf0d1b4064553756a1e81c0b943e842296f2a2af6442e480b846392e6bc"
- "784a4cdc77d1767299ab10119288c21b478b205d560ae86bc9782b04ae2f82fc")
+ "2c94fbbccd6981a22951e4696f72d26aa0b5f7ea32aa48e46a0b6ded909fc3db")
build() {
mkdir -p build
cd build
cmake -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub-$pkgver
- make -j1 univalue leveldb
make
}