aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80c5c317e4be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Joost Molenaar <jjm@j0057.nl>
+
+pkgname=fluent-bit
+
+pkgmaj=0.13
+pkgver=$pkgmaj.7
+pkgrel=1
+epoch=
+
+pkgdesc='Collect data/logs from different sources, unify and send them to multiple destinations.'
+arch=(x86_64)
+url='https://fluentbit.io/'
+license=('Apache')
+groups=()
+
+depends=()
+makedepends=(cmake)
+checkdepends=()
+optdepends=()
+
+provides=()
+conflicts=()
+replaces=()
+
+backup=()
+options=()
+install=
+changelog=
+source=("https://fluentbit.io/releases/$pkgmaj/$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=(9c592bda1ba6fcee2d62f0e2737ab71d)
+validpgpkeys=()
+
+build() {
+ #cd "$pkgname-$pkgver"
+ #./configure --prefix=/usr
+ #make
+
+ cd $pkgname-$pkgver/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_SYSCONFDIR=/etc ..
+ make -j8
+}
+
+package() {
+ cd $pkgname-$pkgver/build
+ make DESTDIR="$pkgdir/" install
+}