summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36542e4b6c75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Nico <d3sox at protonmail dot com>
+pkgname=fluent-reader
+pkgver=1.0.0
+pkgrel=1
+_pkgname="${pkgname}-${pkgver}"
+pkgdesc='Modern desktop RSS reader built with Electron, React, and Fluent UI'
+arch=('any')
+url='https://github.com/yang991178/fluent-reader'
+license=('custom:BSD-3')
+depends=('hicolor-icon-theme')
+makedepends=('nodejs' 'node-gyp')
+provides=('fluent-reader')
+conflicts=('fluent-reader')
+source=("${url}/archive/v${pkgver}.tar.gz"
+ 'fluent-reader.desktop')
+sha256sums=('40e43fbc983e1cfd1ea32c852918ebce88d243f7ed943031696bdc7e01e55784'
+ '8094dd526fcb3bd67913a20224fa8c167068d58b8e0ba51b74e8b74c23f73026')
+
+build() {
+ cd "$_pkgname"
+ npm install
+ npm run build
+ export NODE_ENV=production
+ node_modules/.bin/electron-builder --linux dir -p never
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -d "$pkgdir/opt/"
+ cp -dr --no-preserve=ownership "bin/linux/x64/linux-unpacked" "$pkgdir/opt/$pkgname"
+
+ install -Dm644 -t "$pkgdir/usr/share/applications" "$srcdir/$pkgname.desktop"
+
+ install -Dm644 "build/icons/512x512.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/LICENSE" LICENSE
+}
+