summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2efb086c3095..e565c5123420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,9 +27,12 @@ prepare() {
# overriding CMake flags for aarch64 in order to ensure build
# is not failing
- if [ "$(uname -m)" == "aarch64" ]; then
+ if [[ "$(uname -m)" == "aarch64" ]]; then
export CXXFLAGS="${CXXFLAGS/-fstack-protector-strong/ }"
export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection/ }"
+
+ export CFLAGS="${CFLAGS/-fstack-protector-strong/ }"
+ export CFLAGS="${CFLAGS/-fstack-clash-protection/ }"
fi
cd ${pkgname}-v$pkgver