summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7853f5b7b722
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: garionion <garionion at entr0py.de>
+
+pkgname=fluffychat-bin
+_pkgname=fluffychat
+_file_version=11315923
+pkgver=0.31.3
+pkgrel=1
+pkgdesc="Chat with your friends"
+arch=('x86_64')
+url="https://fluffychat.im/"
+license=('AGPL3')
+depends=('libolm')
+makedepends=('unzip')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=(
+ "fluffychat-${pkgver}.tar.gz::https://gitlab.com/famedly/fluffychat/-/package_files/${_file_version}/download")
+sha256sums=('69da9af832355da6c71a5735bad5c5f46cc0f79966ca2525d74fa66572e1946b')
+
+
+package() {
+ # install
+ install -dm755 ${pkgdir}/opt/${_pkgname}/
+ mv ${_pkgname} ${pkgdir}/opt/${_pkgname}/
+ mv data ${pkgdir}/opt/${_pkgname}/
+ mv lib ${pkgdir}/opt/${_pkgname}/
+
+
+ # link
+ install -dm755 ${pkgdir}/usr/bin
+ ln -s /opt/${_pkgname}/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+
+ # icon
+ install -Dm 644 ${pkgdir}/opt/${_pkgname}/data/flutter_assets/assets/favicon.png ${pkgdir}/usr/share/pixmaps/${_pkgname}.png
+
+ # desktop entry
+
+ install -dm 755 "${pkgdir}/usr/share/applications"
+ cat > ${pkgdir}/usr/share/applications/${_pkgname}.desktop << EOF
+[Desktop Entry]
+Type=Application
+Version=${pkgver}
+Name=FluffyChat
+Comment=Matrix Client. Chat with your friends
+Exec=/opt/${_pkgname}/${_pkgname}
+Icon=${_pkgname}
+Terminal=false
+EOF
+
+}
+
+# vim: set sw=2 ts=2 et: