summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 465f90f4f7be..52f8fcd4d4ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=flutter
-pkgver=beta
-pkgrel=3
+pkgver=0.2.3
+pkgrel=1
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64")
url="https://${pkgname}.io"
@@ -20,11 +20,13 @@ optdepends=("android-sdk"
"python"
"sh")
makedepends=("git" "python")
+backup=("opt/flutter/packages/flutter_test/pubspec.yaml" "opt/flutter/packages/flutter/pubspec.yaml")
+options=(!epmtydirs)
install="${pkgname}.install"
-source=("${pkgname}::git+https://github.com/${pkgname}/${pkgname}#branch=${pkgver}"
+source=("${pkgname}-${pkgver}.tar.xz::https://storage.googleapis.com/flutter_infra/releases/beta/linux/${pkgname}_linux_v${pkgver}-beta.tar.xz"
"${pkgname}.sh"
"${pkgname}.csh")
-sha256sums=("SKIP"
+sha256sums=("4fe85a822093e81cb5a66c7fc263f68de39b5797b294191b6d75e7afcc86aff8"
"1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a"
"7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f")
@@ -39,10 +41,6 @@ package() {
install -Dm755 "${srcdir}/${pkgname}.csh" "${pkgdir}/etc/profile.d/${pkgname}.csh"
install -d "${pkgdir}/opt/${pkgname}/"
cp -ra "${srcdir}/${pkgname}" "${pkgdir}/opt/"
- chown -R "${USER}":users "${pkgdir}/opt/${pgkname}"
- chmod a+r -R "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin"
- chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin"
- chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin/snapshots"
- chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin/snapshots/resources"
- chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin/snapshots/resources/dartdoc"
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod a+rx {} +
+ find "${pkgdir}/opt/${pkgname}" -type f -exec chmod a+r {} +
}