summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 25 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 272be279ae48..465f90f4f7be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,28 @@
pkgname=flutter
pkgver=beta
-pkgrel=2
-pkgdesc="Flutter is a new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
-arch=("any")
+pkgrel=3
+pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
+arch=("x86_64")
url="https://${pkgname}.io"
-license=("https://github.com/${pkgname}/${pkgname}/blob/master/LICENSE")
-depends=("android-sdk")
-optdepends=("android-studio" "intellij-idea-community-edition" "intellij-idea-ultimate-edition")
+license=("custom:https://github.com/${pkgname}/${pkgname}/blob/master/LICENSE")
+depends=("glu" "java-environment" "lib32-libglvnd")
+optdepends=("android-sdk"
+ "android-studio"
+ "bash"
+ "dart"
+ "git"
+ "intellij-idea-community-edition"
+ "intellij-idea-ultimate-edition"
+ "perl"
+ "python"
+ "sh")
+makedepends=("git" "python")
+install="${pkgname}.install"
source=("${pkgname}::git+https://github.com/${pkgname}/${pkgname}#branch=${pkgver}"
- "${pkgname}.install"
"${pkgname}.sh"
"${pkgname}.csh")
sha256sums=("SKIP"
- "b8eb8c1a38e961984fe7d26fc83a86f6aa1b362c4187a1fef55ce5cbc68a8d84"
"1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a"
"7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f")
@@ -25,9 +34,15 @@ build() {
}
package() {
- install -Dm755 "${pkgname}.sh" "${pkgdir}/etc/profile.d/${pkgname}.sh"
- install -Dm755 "${pkgname}.csh" "${pkgdir}/etc/profile.d/${pkgname}.csh"
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/etc/profile.d/${pkgname}.sh"
+ install -Dm755 "${srcdir}/${pkgname}.csh" "${pkgdir}/etc/profile.d/${pkgname}.csh"
install -d "${pkgdir}/opt/${pkgname}/"
cp -ra "${srcdir}/${pkgname}" "${pkgdir}/opt/"
chown -R "${USER}":users "${pkgdir}/opt/${pgkname}"
+ chmod a+r -R "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin"
+ chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin"
+ chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin/snapshots"
+ chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin/snapshots/resources"
+ chmod a+x "${pkgdir}/opt/${pkgname}/bin/cache/dart-sdk/bin/snapshots/resources/dartdoc"
}