summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 24 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91de7a56f909..76a1d53d9c22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname=fluxbox-wm
_pkgname=fluxbox
pkgver=1.3.7
-pkgrel=2
-pkgdesc="A lightweight and highly-configurable window manager compiled without slit toolbar and systemtray"
+pkgrel=3
+pkgdesc="Fluxbox window manager only: compiled without slit, toolbar and systemtray"
arch=('i686' 'x86_64')
url="http://www.fluxbox.org"
license=('MIT')
@@ -15,23 +15,39 @@ conflicts=('fluxbox' 'fluxbox-noslit')
depends=('libxft' 'libxpm' 'libxinerama' 'libxrandr' 'imlib2' 'fribidi')
optdepends=('xorg-xmessage: for using the fbsetbg and fluxbox-generate_menu utilities')
options=('!makeflags')
-source=(http://downloads.sourceforge.net/sourceforge/${_pkgname}/${_pkgname}-${pkgver}.tar.xz
- fluxbox.desktop)
-sha1sums=('c53940f5b70dfad39f4a3fa6b0e95072c2b3e9db'
- 'f3f83b8ce84d79c2f8670ef687e0dd89ab0552b8')
+source=("http://downloads.sourceforge.net/sourceforge/${_pkgname}/${_pkgname}-${pkgver}.tar.xz"
+ '0001-do-not-leave-stale-oplock-behind.patch'
+ '0002-send-ConfigureNotify-using-root-coordinates.patch'
+ '0003-c-plus-plus-17.patch'
+ '0004-window-menu.patch')
+sha256sums=('fc8c75fe94c54ed5a5dd3fd4a752109f8949d6df67a48e5b11a261403c382ec0'
+ '9c486f454f46a51cb1b7cb65de812faa12e2a1cce13785c349b488f051a01470'
+ '66f64c67e5c99b2c6bf139ba2f7a3ff9fcb613c5b49b0038c42cc55cc00153dc'
+ 'a743324fb0c684be44fbcb3ff626f604057fce42fe1dda774515c1b24efbf418'
+ 'b9a4cdc5637eb5c275a9de2f43dd13987233a2c2fa843deb9958127e04960ac2')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+
+ patch -Np1 < ../0001-do-not-leave-stale-oplock-behind.patch
+ patch -Np1 < ../0002-send-ConfigureNotify-using-root-coordinates.patch
+ patch -Np1 < ../0003-c-plus-plus-17.patch
+ patch -Np1 < ../0004-window-menu.patch
+}
build() {
cd ${_pkgname}-${pkgver}
./configure --prefix=/usr \
--enable-xft --enable-xinerama \
--enable-imlib2 --enable-nls \
- --disable-slit --disable-toolbar --disable-systray
+ --disable-slit \
+ --disable-systray \
+ --disable-toolbar
make
}
package() {
cd ${_pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
- install -D -m644 "${srcdir}/fluxbox.desktop" "${pkgdir}/usr/share/xsessions/fluxbox.desktop"
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}