summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6aaadadd6785
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: mztikk <mztikk@outlook.de>
+pkgbase=fmnl
+pkgname=fmnl-git
+conflicts=('fmnl')
+provides=('fmnl')
+pkgver=0.1.0
+pkgrel=1
+makedepends=('rust' 'cargo' 'git')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="Formats newlines of input with a given string"
+url="https://github.com/mztikk/fmnl"
+source=('fmnl::git+https://github.com/mztikk/fmnl.git#branch=master')
+license=('MIT')
+
+package() {
+ cd $srcdir
+ cargo install --no-track --all-features --root "$pkgdir/usr/" --path ./fmnl
+}
+sha256sums=('SKIP')