summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02463631071d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Sergey Khobta <hxss@ya.ru>
+
+pipname=folderpreview
+pkgname=$pipname
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Generates folder thumbs using child files thumbs"
+arch=(any)
+url="https://gitlab.com/hxss-linux/folderpreview"
+license=(MIT)
+depends=(
+ 'python-dbus-next'
+ 'python-pyxdg'
+ 'python-yaml'
+ 'python-parse'
+ 'python-gobject'
+ 'python-pyvips'
+ 'python-systemd'
+ 'python-colorlog'
+)
+makedepends=(
+ 'python-pip'
+ 'curl'
+ 'jq'
+)
+install='INSTALL'
+provides=($pipname)
+replaces=('folderpreview-git')
+
+pkgver() {
+ curl -s https://pypi.org/pypi/$pipname/json | jq -r .info.version
+}
+
+package() {
+ pip install $pipname \
+ --root=$pkgdir \
+ --no-user \
+ --no-deps \
+ --ignore-installed \
+ --quiet
+
+ install -Dm644 $(find $pkgdir -name LICENSE*) \
+ -t "$pkgdir/usr/share/licenses/$pkgname"
+}