summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c5bd3708493
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Maarten van Gompel <proycon at anaproy.nl>
+
+pkgname=foliautils
+pkgver=0.5
+pkgrel=1
+pkgdesc="Tools for working with the FoLiA format, based on libfolia. *NOT* the same as Python package FoLiA-tools!"
+arch=('i686' 'x86_64')
+url="http://proycon.github.io/folia"
+license=('GPL')
+depends=('ticcutils' 'ucto>=0.9.4' 'libxml2' 'libfolia>=1.5' 'libexttextcat')
+provides=('foliautils')
+conflicts=('foliatools' 'foliautils')
+makedepends=('libtool' 'autoconf')
+options=(!libtool)
+_gituser="LanguageMachines"
+_gitname="foliautils"
+source=(https://github.com/LanguageMachines/foliautils/archive/v0.5.tar.gz)
+md5sums=(0c2f1e76e3b6ab2029c68e0ba8db4c29)
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ bash bootstrap.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}