summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 35 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e2752a8be66..27880168670f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,52 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=fontbakery
-pkgver=0.7.38
+pkgver=0.12.6
pkgrel=1
pkgdesc='A command-line tool for checking the quality of font projects'
arch=(any)
url="https://github.com/googlefonts/$pkgname"
-license=(Apache)
-_py_deps=(beautifulsoup4
- defcon
- fonttools
- lxml
- fs # optdepends of fonttols required for [ufo]
- opentype-sanitizer
- protobuf
- requests
- unicodedata2) # optdepends of fonttools required for [unicode]
-depends=(python
+license=(Apache-2.0)
+_pydeps=(axisregistry
+ beautifulsoup4
+ beziers
+ cmarkgfm
+ collidoscope
+ defcon
+ fonttools
+ fs # for fonttols[ufo]
+ gflanguages
+ glyphsets
+ lxml
+ opentype-sanitizer
+ protobuf
+ pyyaml
+ requests
+ rich
+ stringbrewer
+ toml
+ ufo2ft
+ unicodedata2 # for fonttools[unicode]
+ vharfbuzz)
+depends=(dehinter
font-v
+ python
ttfautohint
ufolint)
-depends+=("${_py_deps[@]/#/python-}")
-makedepends=(python-setuptools-scm)
+depends+=("${_pydeps[@]/#/python-}")
+makedepends=(python-{build,installer,wheel}
+ python-setuptools-scm)
_archive="$pkgname-$pkgver"
-source=("$_archive.tgz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('9eaa2b0b43df278cc0eef4fcb4561573ca55ba9da9e99626f0a33ae5f22d807e')
-
-prepare() {
- cd "$pkgname-$pkgver"
- echo "version = '$pkgver'" > "Lib/$pkgname/_version.py"
- sed -i -e '/use_scm_version/d' setup.py
-}
+# source=("$url/archive/v$pkgver/$_archive.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$_archive.tar.gz")
+sha256sums=('fa2baeed929362250db4e488e381e2efdc350ccc63eede57486aa987986e8c76')
build() {
- cd "$_archive"
- python setup.py build
+ cd "$_archive"
+ python -m build -wn
}
package() {
- cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$_archive"
+ python -m installer -d "$pkgdir" dist/*.whl
}