summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 24 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e2752a8be66..ae379efed63d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,51 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=fontbakery
-pkgver=0.7.38
+pkgver=0.8.10
pkgrel=1
pkgdesc='A command-line tool for checking the quality of font projects'
arch=(any)
url="https://github.com/googlefonts/$pkgname"
license=(Apache)
-_py_deps=(beautifulsoup4
+_py_deps=(axisregistry
+ beautifulsoup4
+ beziers
+ cmarkgfm
+ collidoscope
defcon
fonttools
- lxml
fs # optdepends of fonttols required for [ufo]
+ gflanguages
+ glyphsets
+ lxml
opentype-sanitizer
protobuf
+ pyyaml
requests
- unicodedata2) # optdepends of fonttools required for [unicode]
-depends=(python
+ rich
+ stringbrewer
+ toml
+ ufo2ft
+ unicodedata2 # optdepends of fonttools required for [unicode]
+ vharfbuzz)
+depends=(dehinter
font-v
+ python
ttfautohint
ufolint)
depends+=("${_py_deps[@]/#/python-}")
-makedepends=(python-setuptools-scm)
+makedepends=(python-{build,installer,wheel} python-setuptools-scm)
_archive="$pkgname-$pkgver"
-source=("$_archive.tgz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('9eaa2b0b43df278cc0eef4fcb4561573ca55ba9da9e99626f0a33ae5f22d807e')
-
-prepare() {
- cd "$pkgname-$pkgver"
- echo "version = '$pkgver'" > "Lib/$pkgname/_version.py"
- sed -i -e '/use_scm_version/d' setup.py
-}
+# source=("$_archive.tgz::$url/archive/v$pkgver.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$_archive.tar.gz")
+sha256sums=('50838d85d9f17ac14578d48a9074e7a03d3bccc2e706d7e217455734444e31e0')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}