summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 19 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46b59ff9ce76..5fa48da4331f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,33 @@
-# Maintainer: Christopher Davis <brainblastedmods@gmail.com>
-# Submitter: Falk Alexander Seidl <fa@terminal.run>
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+# Contributor: Falk Alexander Seidl <fa@terminal.run>
pkgname=fractal-git
_gitname=fractal
-pkgver=r840.d1dba64
-pkgrel=1
-pkgdesc="Matrix.org gtk+ client"
+epoch=1
+pkgver=5.beta1.r6.g5816bdbb
+pkgrel=2
+pkgdesc="Matrix messaging app for GNOME written in Rust"
arch=('i686' 'x86_64')
license=('GPL3')
-url="https://gitlab.gnome.org/World/fractal"
-depends=('gtk3' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good'
- 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'gspell')
-conflics=('fractal')
-provides=('fractal')
-makedepends=('gtk3' 'rust' 'pkg-config' 'git' 'meson')
-source=("git+https://gitlab.gnome.org/World/fractal.git")
+url="https://gitlab.gnome.org/GNOME/fractal"
+depends=('gtk4' 'gtksourceview5' 'gst-plugins-base-libs' 'gst-editing-services'
+ 'libadwaita>=1:1.3alpha' 'pipewire' 'libshumate' 'org.freedesktop.secrets'
+ 'xdg-desktop-portal')
+conflicts=('fractal')
+provides=("fractal=$pkgver" 'fractal-next')
+replaces=('fractal-next')
+makedepends=('rust' 'git' 'meson' 'clang')
+source=("git+https://gitlab.gnome.org/GNOME/fractal.git")
md5sums=('SKIP')
-
+
pkgver() {
- cd "${srcdir}/${_gitname}/"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$_gitname"
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${srcdir}/${_gitname}/"
- meson . _build --prefix=/usr
+ arch-meson . _build
ninja -C _build
}