summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0255dcef074c..82ad89996fcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,28 @@
pkgname=fractal-git
_gitname=fractal
-pkgver=r1614.f39555b
+pkgver=5.alpha.r724.b55752c1
pkgrel=1
pkgdesc="Matrix messaging app for GNOME written in Rust"
arch=('i686' 'x86_64')
license=('GPL3')
url="https://gitlab.gnome.org/GNOME/fractal"
-depends=('gtk3' 'libhandy' 'gtksourceview3' 'gstreamer' 'gst-plugins-base-libs' 'gst-plugins-bad' 'gst-editing-services' 'gst-libav' 'gspell')
-optdepends=('gnome-keyring: secrets service')
-conflics=('fractal')
+depends=('gtk4' 'gtksourceview5' 'gst-plugins-base-libs' 'gst-editing-services' 'gspell' 'libadwaita>=1:1.2.alpha' 'pipewire' 'libshumate' 'org.freedesktop.secrets')
+conflicts=('fractal')
provides=('fractal')
-makedepends=('rust' 'gst-editing-services' 'pkg-config' 'git' 'meson')
-source=("git+https://gitlab.gnome.org/World/fractal.git")
+makedepends=('rust' 'git' 'meson' 'clang')
+source=("git+https://gitlab.gnome.org/GNOME/fractal.git")
md5sums=('SKIP')
-
+
pkgver() {
- cd "${srcdir}/${_gitname}/"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$_gitname"
+ (
+ set -o pipefail
+
+ # the -next rewrite is a completely separate git history, which does not have any tags yet
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "5.alpha.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {