summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3df1bb17a501..129a6fc4ec0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=fractal-git
_gitname=fractal
epoch=1
-pkgver=5.alpha1.r55.g92692649
+pkgver=5.alpha1.r166.g52ed7d3c
pkgrel=1
pkgdesc="Matrix messaging app for GNOME written in Rust"
arch=('i686' 'x86_64')
license=('GPL3')
url="https://gitlab.gnome.org/GNOME/fractal"
-depends=('gtk4' 'gtksourceview5' 'gst-plugins-base-libs' 'gst-editing-services' 'gspell' 'libadwaita>=1:1.2.alpha' 'pipewire' 'libshumate' 'org.freedesktop.secrets')
+depends=('gtk4' 'gtksourceview5' 'gst-plugins-base-libs' 'gst-editing-services' 'gspell' 'libadwaita>=1:1.3alpha' 'pipewire' 'libshumate' 'org.freedesktop.secrets')
conflicts=('fractal')
provides=("fractal=$pkgver" 'fractal-next')
replaces=('fractal-next')
@@ -17,6 +17,11 @@ makedepends=('rust' 'git' 'meson' 'clang')
source=("git+https://gitlab.gnome.org/GNOME/fractal.git")
md5sums=('SKIP')
+prepare() {
+ cd "$_gitname"
+ git tag -d 4.4.2-beta1 # upstream made a mistake and tagged this on main
+}
+
pkgver() {
cd "$_gitname"
(