summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b314fa813ff8..9d6a13267fa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname=frappe-books-bin
_pkgname=frappe-books
+pkgname="${_pkgname}-bin"
pkgver=0.11.0
-pkgrel=1
+pkgrel=2
pkgdesc="Modern desktop accounting for freelancers and small-businesses."
arch=('x86_64')
url="https://frappebooks.com/"
_githuburl="https://github.com/frappe/books"
license=('AGPL3')
-options=()
-conflicts=(frappe-books)
-depends=(alsa-lib gtk3 at-spi2-core nss)
+conflicts=("${_pkgname}-appimage")
+depends=(alsa-lib gtk3 at-spi2-core nss glibc libx11 libcups pango libdrm libxext libxrandr nspr glib2 libxcomposite \
+ mesa libxcb gcc-libs dbus expat libxdamage libxfixes libxkbcommon hicolor-icon-theme cairo)
source=("${_pkgname}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
-sha512sums=('49ba1db3e7d04de641a35a3c4dfcddf46e153b0424d91136209795d9a411a6159a7a2b70aed43f0068cb500641d3967123e1502263fa4a4171090bebc253d13d')
+sha256sums=('64770914045c7316298d0730ee6615121f9888bb7c0f15b51d69cec0bbc9107b')
package() {
bsdtar -xvf data.tar.xz -C "${pkgdir}"
sed 's/Finance/Utility/g' -i "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
-}
+} \ No newline at end of file