summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20f185bf9b4e..db20c5e5fcff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
pkgname=freecad
_pkgver=0.18
-_count=16155
-_commit=9ae129705652eec6be426211e5eaaa16c847b7c5
+_count=16158
+_commit=783e1346c7a078f5265c3f0c6a927d09a8c1fe70
pkgver=$_pkgver.$_count
pkgrel=1
pkgdesc='A general purpose 3D CAD modeler'
@@ -30,13 +30,10 @@ sha256sums=('SKIP'
'1d98fa4e62f352966eb357c93f54b1f0bf562931e8323bf70a83b5e221a5fb14')
_backports=(
+ 299368b1b278f94f579c110be179cf6023882ca5 # Workaround for messy SHIBOKEN_MICRO_VERSION definition.
17ed2b196a58afbbc3cc1bb99f6eb76060171ad2 # [Cmake] Update FindPySide2Tools for PySide2 5.14 - issue #4229
1666b28836baa79b26b707afb1e97c2a0855eb1f # Change IF(...LESS...) into IF(...VERSION_LESS...)
6eacb17b3e03d20039b85c9daebab9e44386d6bf # Update swigpyrun.in for Python 3.8
- 851e3d9847c5043a604a544b502c51e8c628e96c # add missing std:: namespace to build on Debian 10
- bf5923c0f360f43703bf0c2d8b1e52ac246a9c11 # add missing std:: namespace to build on Debian 10
- 2a92051192782930f53f8e3dab011dd8382ca8c3 # add missing std:: namespace to build on Debian 10
- 50957037764de76bdc0244e5d49f8c5bdcbc4e45 # add missing std:: namespace to build on Debian 10
)
prepare() {
@@ -44,10 +41,14 @@ prepare() {
if ((${#_backports[@]})); then
git cherry-pick --quit
- git cherry-pick -n -x -Xours -Xignore-space-change "${_backports[@]}" \
- || true # Kind of a hack, but the last commit does not apply cleanly
- git rm src/Mod/TechDraw/App/Cosmetic.cpp # Fix file not present in 0.18
+ git cherry-pick -n -x -Xours -Xignore-space-change "${_backports[@]}"
fi
+
+ # Sigh… Why can't upstream backport properly?
+ sed -i '38a using namespace std\;\r' src/Mod/Raytracing/App/RayFeature.cpp # Fixup d13e777 by partial application of 5095703
+
+ # Fix for Qt 5.15
+ sed -i 's/\(.*\)include <QPainter>$/&\n\1include <QPainterPath>/' src/Mod/Image/Gui/OpenGLImageBox.cpp
}
build() {
@@ -63,13 +64,13 @@ build() {
-DFREECAD_USE_QT_FILEDIALOG=ON \
-DBUILD_QT5=ON \
-DPYTHON_EXECUTABLE=/usr/bin/python
- make
+ cmake --build .
}
package() {
cd "${srcdir}/FreeCAD"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install .
# Symlink to /usr/bin
install -dm755 "${pkgdir}/usr/bin"