summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16270fbe0f67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+_pkgname=freecheck
+pkgname=freecheck-git
+pkgver=0.30_4_g3f4fe6f
+pkgrel=2
+_branch=devel
+url=https://github.com/alerque/$_pkgname
+pkgdesc='A blank check printer that adds MICR codes and check templates to blank stock.'
+arch=('any')
+license=('GPL2')
+depends=('perl' 'gnumicr')
+optdepends=(
+ 'cups: printing support'
+ 'ghostscript: output to pdf files'
+ )
+source=("git://github.com/alerque/$_pkgname.git#branch=$_branch")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/^v//;s/-/_/g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make prefix=$pkgdir/ install
+}
+