summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93d3f1b32dac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Brandon Golway <brando56894 at gmail dot com>
+_pkgname=freenas-vm-tools
+pkgname="$_pkgname"-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="Bhyve VM tools for FreeNAS 10"
+arch=(x86_64)
+url="https://www.freenas.org"
+license=('GPL')
+depends=(poco)
+makedepends=(git cmake binutils clang libmariadbclient libtool unixodbc)
+provides=('freenas-vm-tools')
+conflicts=('freenas-vm-tools')
+source=("git+https://github.com/freenas/${_pkgname}.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$_pkgname"
+ export CXX=clang++
+ cmake .
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/freenas-vm-tools/systemd"
+ mkdir -p $pkgdir/usr/lib/systemd/system
+ install -m755 freenas-vm-tools.service $pkgdir/usr/lib/systemd/system/freenas-vm-tools.service
+}