summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9db3879367a8..5c630eb4b563 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Muflone http://www.muflone.com/contacts/english/
pkgname=freeoffice
-pkgver=931
+pkgver=934
pkgrel=1
pkgdesc="A complete, reliable, lightning-fast and Microsoft Office-compatible office suite with a word processor, spreadsheet, and presentation graphics software."
arch=('x86_64')
url="http://www.freeoffice.com/"
license=('custom')
-depends=('libxrandr' 'libgl' 'xdg-utils' 'shared-mime-info' 'gtk-update-icon-cache' 'desktop-file-utils')
+depends=('libxrandr' 'libgl' 'xdg-utils' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'curl')
makedepends=('chrpath')
install="${pkgname}.install"
source=("http://www.softmaker.net/down/softmaker-${pkgname}-${pkgver}-amd64.tgz"
@@ -17,7 +18,7 @@ source=("http://www.softmaker.net/down/softmaker-${pkgname}-${pkgver}-amd64.tgz"
"${pkgname}-textmaker.desktop"
"${pkgname}-planmaker.desktop"
"${pkgname}-presentations.desktop")
-sha256sums=('10a23e591803227fcb9692bddfd7d9c3491a716da2e94c28c4175e66e9ec2dad'
+sha256sums=('8372490f1a2ad510a870c2818602a8cf98f45afa6afda22b5502b4b58d98d02d'
'0437328f3fddf93e18ad3df270971802c2e0fcaf3f030588c1301767a968da69'
'c90e2575c71f03f0b627e4f6c70f437b9c40e5878bf9f553a4244b4a1f6dbd3c'
'e6bc7608e58f44b55654c5d1fc93d442a400de638e2cbc6d5a3b3a8fbceaa0e4'
@@ -41,18 +42,18 @@ build() {
}
package() {
- msg2 "Installing package files..."
+ # Install package files
install -d "${pkgdir}/usr/lib"
cp -r "${srcdir}/${pkgname}" "${pkgdir}/usr/lib"
- msg2 "Installing license file..."
+ # Installing license file
install -d "${pkgdir}/usr/share/licenses/${pkgname}"
ln -s "/usr/lib/${pkgname}/mime/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
- msg2 "Installing program executables..."
+ # Install program executables
install -d "${pkgdir}/usr/bin"
install -m 755 -t "${pkgdir}/usr/bin" "${srcdir}/${pkgname}-planmaker"
install -m 755 -t "${pkgdir}/usr/bin" "${srcdir}/${pkgname}-textmaker"
install -m 755 -t "${pkgdir}/usr/bin" "${srcdir}/${pkgname}-presentations"
- msg2 "Installing icons..."
+ # Installing icons
for size in 16 32 48
do
install -d "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps"
@@ -65,12 +66,12 @@ package() {
ln -s "/usr/lib/${pkgname}/icons/prd_${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/mimetypes/application-x-prd.png"
ln -s "/usr/lib/${pkgname}/icons/tmd_${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/mimetypes/application-x-tmd.png"
done
- msg2 "Installing desktop files..."
+ # Install desktop files
install -d "${pkgdir}/usr/share/applications"
install -m 755 -t "${pkgdir}/usr/share/applications" "${pkgname}-textmaker.desktop"
install -m 755 -t "${pkgdir}/usr/share/applications" "${pkgname}-planmaker.desktop"
install -m 755 -t "${pkgdir}/usr/share/applications" "${pkgname}-presentations.desktop"
- msg2 "Installing mime file..."
+ # Installing mime file
install -d "${pkgdir}/usr/share/mime/packages"
install -m 644 -t "${pkgdir}/usr/share/mime/packages" "${srcdir}/${pkgname}/mime/softmaker-freeoffice18.xml"
}