summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f761119dfb5f..9db3879367a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Muflone http://www.muflone.com/contacts/english/
pkgname=freeoffice
-pkgver=767
+pkgver=931
pkgrel=1
pkgdesc="A complete, reliable, lightning-fast and Microsoft Office-compatible office suite with a word processor, spreadsheet, and presentation graphics software."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.freeoffice.com/"
license=('custom')
-depends=('xdg-utils' 'shared-mime-info' 'gtk-update-icon-cache' 'desktop-file-utils')
-depends_i686=('libxrender' 'libxrandr' 'libgl')
-depends_x86_64=('lib32-gcc-libs' 'lib32-libxmu' 'lib32-libxrender' 'lib32-libxrandr' 'lib32-libgl')
+depends=('libxrandr' 'libgl' 'xdg-utils' 'shared-mime-info' 'gtk-update-icon-cache' 'desktop-file-utils')
+makedepends=('chrpath')
install="${pkgname}.install"
-source=("http://www.softmaker.net/down/softmaker-${pkgname}-${pkgver}.tgz"
+source=("http://www.softmaker.net/down/softmaker-${pkgname}-${pkgver}-amd64.tgz"
"${pkgname}-textmaker"
"${pkgname}-planmaker"
"${pkgname}-presentations"
"${pkgname}-textmaker.desktop"
"${pkgname}-planmaker.desktop"
"${pkgname}-presentations.desktop")
-sha256sums=('53ba8df49ed41b338c52b755878e136760e53f41771d54fee856c012a023d617'
+sha256sums=('10a23e591803227fcb9692bddfd7d9c3491a716da2e94c28c4175e66e9ec2dad'
'0437328f3fddf93e18ad3df270971802c2e0fcaf3f030588c1301767a968da69'
'c90e2575c71f03f0b627e4f6c70f437b9c40e5878bf9f553a4244b4a1f6dbd3c'
'e6bc7608e58f44b55654c5d1fc93d442a400de638e2cbc6d5a3b3a8fbceaa0e4'
@@ -26,10 +25,19 @@ sha256sums=('53ba8df49ed41b338c52b755878e136760e53f41771d54fee856c012a023d617'
'518913a4e3edb1f38dec65b865cf0687d5a4a5a1ecaa7fb5d653d5516a4d2ff8'
'2b305734e63c5fba12def3c6ddfa79ef711f1c857fe68250b0d03d56df2bd980')
+prepare() {
+ xz -d "freeoffice2018.tar.lzma"
+}
+
build() {
[ -d "${pkgname}" ] && rm -rf "${pkgname}"
mkdir "${pkgname}"
- tar xz -f freeoffice.tgz -C "${pkgname}"
+ tar x -f "freeoffice2018.tar" -C "${pkgname}"
+ # Remove insecure RPATH
+ cd "${pkgname}"
+ chrpath --delete "textmaker"
+ chrpath --delete "planmaker"
+ chrpath --delete "presentations"
}
package() {
@@ -38,7 +46,7 @@ package() {
cp -r "${srcdir}/${pkgname}" "${pkgdir}/usr/lib"
msg2 "Installing license file..."
install -d "${pkgdir}/usr/share/licenses/${pkgname}"
- ln -s "/usr/lib/${pkgname}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+ ln -s "/usr/lib/${pkgname}/mime/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
msg2 "Installing program executables..."
install -d "${pkgdir}/usr/bin"
install -m 755 -t "${pkgdir}/usr/bin" "${srcdir}/${pkgname}-planmaker"
@@ -64,5 +72,5 @@ package() {
install -m 755 -t "${pkgdir}/usr/share/applications" "${pkgname}-presentations.desktop"
msg2 "Installing mime file..."
install -d "${pkgdir}/usr/share/mime/packages"
- install -m 644 -t "${pkgdir}/usr/share/mime/packages" "${srcdir}/${pkgname}/mime/softmaker-freeoffice16.xml"
+ install -m 644 -t "${pkgdir}/usr/share/mime/packages" "${srcdir}/${pkgname}/mime/softmaker-freeoffice18.xml"
}