summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 13 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f786db06466e..68d45474dbd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,33 @@
-# Maintainer: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
-# shellcheck disable=2034
-# shellcheck disable=2148
+# Maintainer Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=freeorion
-pkgver=0.4.8
+pkgver=0.4.9
pkgrel=1
-pkgdesc="turn-based space empire and galactic conquest (4X) computer game"
-url="http://www.freeorion.org/"
+pkgdesc='Turn-based space empire and galactic conquest (4X) computer game'
+url='http://www.freeorion.org/'
arch=('i686' 'x86_64')
license=('GPL2')
depends=('boost-libs' 'python2' 'sdl2' 'libvorbis' 'glew' 'openal' 'hicolor-icon-theme' 'freetype2')
makedepends=('boost' 'cmake')
+provides=('freeorion')
conflicts=('freeorion-git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/freeorion/freeorion/releases/download/v0.4.8/FreeOrion_v0.4.8_2018-08-23.26f16b0_Source.tar.gz")
-md5sums=('c3ad0186b868e939688483713d0d8dec')
-
-prepare() {
- # shellcheck disable=2154
- cd "$srcdir"/src-tarball || exit 1
-
- mkdir -p build
-}
+source=("https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('66e11dfeb836ea04474a8539713737ee')
build() {
- # shellcheck disable=2154
- cd "$srcdir"/src-tarball/build || exit 1
-
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p build
+ cd "${srcdir}/${pkgname}-${pkgver}"/build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_LIBDIR=lib \
..
-
make
}
package() {
- # shellcheck disable=2154
- cd "$srcdir"/src-tarball/build || exit 1
-
- # shellcheck disable=2154
+ cd "${srcdir}/${pkgname}-${pkgver}"/build
make DESTDIR="$pkgdir" install
-}
+} \ No newline at end of file