summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9bcf06eb5ff0..e8f6e00c1da8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc='A scalable, open source telephony platform'
arch=('i686' 'x86_64')
url='https://freeswitch.org/'
license=('MPL')
-depends=('libedit' 'speex')
+depends=('libedit' 'speex' 'openssl-1.0')
makedepends=('libjpeg-turbo' 'yasm')
optdepends=()
provides=('freeswitch')
@@ -131,7 +131,10 @@ build() {
fi
# Work around FreeSWITCH bug FS-10257
- export CFLAGS="${CFLAGS} -Wno-parentheses -Wno-deprecated-declarations"
+ export CFLAGS="${CFLAGS} -Wno-parentheses -Wno-deprecated-declarations -Wno-int-in-bool-context"
+
+ # Use OpenSSL 1.0 until upstream supports 1.1.
+ export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
cp "${srcdir}"/modules.conf .