summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 12 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 291eb7b4310c..906354459f73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Jack L. Frost <fbt@fleshless.org>
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# Contributor: Jack L. Frost <fbt@fleshless.org>
# Contributor: Corelli <corelli AT sent DOT com>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: intelfx <intelfx100 [at] gmail [dot] com>
@@ -6,17 +7,18 @@
# Contributor: zman0900 <zman0900@gmail.com>
pkgname=freshplayerplugin-git
-pkgver=v0.3.4.r21.g7ba5f2d
+pkgver=0.3.5.r21.g4776eeb
pkgrel=1
pkgdesc='PPAPI-host NPAPI-plugin adapter.'
-arch=( 'i686' 'x86_64' )
+arch=('i686' 'x86_64')
url='https://github.com/i-rinat/freshplayerplugin'
-license=( 'MIT' )
-depends=( 'pango' 'alsa-lib' 'freetype2' 'libevent' 'gtk3' 'libgl' 'v4l-utils' 'ffmpeg' )
-makedepends=( 'cmake' 'ragel' 'git' )
-conflicts=( 'freshplayerplugin' )
-source=( "${pkgname}::git+${url}" "${pkgname}.install" )
+license=('MIT')
+depends=('pango' 'alsa-lib' 'freetype2' 'libevent' 'gtk2' 'libgl' 'v4l-utils' 'ffmpeg' 'icu')
+makedepends=('cmake' 'ragel' 'git')
+conflicts=('freshplayerplugin')
+source=("${pkgname}::git+${url}")
install="${pkgname}.install"
+sha1sums=('SKIP')
optdepends=(
'chromium-pepper-flash: for the necessary Pepper plugin'
@@ -28,29 +30,19 @@ optdepends=(
pkgver() {
cd "$pkgname"
-
- if git_version=$( git describe --long --tags 2>/dev/null ); then
- IFS='-' read last_tag tag_rev commit <<< "$git_version"
- printf '%s.r%s.%s' "$last_tag" "$tag_rev" "$commit"
- else
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- fi
+ git describe --tags | sed -e 's:v::' -e 's:-:.r:' -e 's:-:.:g'
}
build() {
cd "$pkgname"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DWITH_GTK=3
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd "$pkgname"
-
make DESTDIR="${pkgdir}" install
install -Dm644 data/freshwrapper.conf.example "${pkgdir}/usr/share/${pkgname}/freshwrapper.conf.example"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-sha1sums=('SKIP'
- '331a3b3877249eaf1c3db917bde1dea6c4d374ab')