summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afc19e0c58d6..81ac7b982e51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='frr'
pkgver='7.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, NHRP and EIGRP.'
arch=('any')
url="https://frrouting.org/"
@@ -16,14 +16,24 @@ conflicts=('quagga' 'babeld' 'quagga_cumulus')
provides=('quagga' 'quagga_cumulus')
source=("https://github.com/FRRouting/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.sysusers"
- "${pkgname}.tmpfiles")
+ "${pkgname}.tmpfiles"
+ "${pkgname}_6.0_systemd_arch.patch"
+ "${pkgname}_7.0_Archlinux.patch")
sha256sums=('15b62dc0c52531e4bcefa6b830e9b9b07d1d0f189c2110307dbc19d80b719354'
'9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e'
- '6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89')
+ '6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89'
+ '9d98a0b5d7016cb66fe3cbec234f70327f0a961de47f7eae39a5bd4477b072ce'
+ '4bfa5c8014869741cae034c6dfb133acfe5c4dbe37838770e36a6796dc411b39')
prepare() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
+ # https://github.com/FRRouting/frr/issues/1422
+ patch -p1 -i "${srcdir}/${pkgname}_6.0_systemd_arch.patch"
+
+ # https://github.com/FRRouting/frr/issues/4167
+ patch -p1 -i "${srcdir}/${pkgname}_7.0_Archlinux.patch"
+
autoreconf -fvi
./configure \
--prefix="/usr" \
@@ -63,6 +73,9 @@ package() {
sed -ri 's|/var/run/frr|/run/frr|g' "${pkgname}.logrotate"
sed -ri 's|/usr/lib/frr/|/usr/bin/|g' "${pkgname}.service"
install -Dm0644 "${pkgname}.logrotate" "${pkgdir}/etc/logrotate.d/${pkgname}"
+ for d in babeld bgpd bfdd eigrpd isisd ldpd nhrpd ospf6d ospfd ospfd-instance@ pbrd pimd ripd ripngd staticd zebra; do
+ install -Dm0644 ${d}.service "${pkgdir}/usr/lib/systemd/system/${d}.service"
+ done
install -Dm0644 "daemons" "${pkgdir}/etc/frr/daemons.conf"
install -Dm0644 "${pkgname}.pam" "${pkgdir}/etc/pam.d/${pkgname}"
install -Dm0644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"