summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 21 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5cdbe24a438c..0a11fef9905d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,21 @@
pkgname='frr'
pkgver='7.0'
-pkgrel='3'
+pkgrel='4'
pkgdesc='FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, NHRP and EIGRP.'
arch=('any')
url="https://frrouting.org/"
license=('GPL2')
-depends=('libcap' 'libnl' 'readline' 'ncurses' 'perl' 'pam' 'json-c' 'net-snmp' 'rtrlib'
- 'libyang' 'libunwind')
-makedepends=('gcc' 'net-snmp' 'bison' 'c-ares' 'perl-xml-libxml' 'python-sphinx')
+depends=('libcap' 'libnl' 'readline' 'ncurses' 'perl' 'pam' 'json-c' 'net-snmp'
+ 'rtrlib' 'libyang' 'libunwind')
+makedepends=('net-snmp' 'bison' 'c-ares' 'perl-xml-libxml' 'python-sphinx')
checkdepends=('python-pytest')
+optdepends=('rsyslog: syslog support')
conflicts=('quagga' 'babeld' 'quagga_cumulus')
provides=('quagga' 'quagga_cumulus')
+backup=("etc/${pkgname}/${pkgname}.conf"
+ "etc/${pkgname}/daemons.conf"
+ "etc/${pkgname}/vtysh.conf")
source=("https://github.com/FRRouting/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.sysusers"
"${pkgname}.tmpfiles"
@@ -23,7 +27,7 @@ sha256sums=('15b62dc0c52531e4bcefa6b830e9b9b07d1d0f189c2110307dbc19d80b719354'
'9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e'
'6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89'
'9d98a0b5d7016cb66fe3cbec234f70327f0a961de47f7eae39a5bd4477b072ce'
- '4bfa5c8014869741cae034c6dfb133acfe5c4dbe37838770e36a6796dc411b39')
+ '93b2cb90ca438841db38d582708e12d4bed77f498e1a494057a804b31bdc323a')
prepare() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
@@ -40,7 +44,7 @@ prepare() {
--sbindir="/usr/bin" \
--sysconfdir="/etc/${pkgname}" \
--localstatedir="/run/${pkgname}" \
- --enable-exampledir="/etc/${pkgname}" \
+ --enable-exampledir="/usr/share/doc/${pkgname}/examples" \
--with-libpam \
--enable-snmp="agentx" \
--enable-multipath=256 \
@@ -69,17 +73,26 @@ package() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- cd "redhat"
+ pushd "redhat"
sed -ri 's|/var/run/frr|/run/frr|g' "${pkgname}.logrotate"
sed -ri 's|/usr/lib/frr/|/usr/bin/|g' "${pkgname}.service"
install -Dm0644 "${pkgname}.logrotate" "${pkgdir}/etc/logrotate.d/${pkgname}"
for d in babeld bgpd bfdd eigrpd isisd ldpd nhrpd ospf6d ospfd ospfd-instance@ pbrd pimd ripd ripngd staticd zebra; do
install -Dm0644 ${d}.service "${pkgdir}/usr/lib/systemd/system/${d}.service"
done
- install -Dm0644 "daemons" "${pkgdir}/etc/frr/daemons.conf"
install -Dm0644 "${pkgname}.pam" "${pkgdir}/etc/pam.d/${pkgname}"
install -Dm0644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
install -Dm0644 "${srcdir}/${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
install -Dm0644 "${srcdir}/${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+ popd
+
+ pushd "tools/etc"
+ install -Dm0644 "${pkgname}/daemons" "${pkgdir}/etc/${pkgname}/daemons.conf"
+ install -Dm0644 "iproute2/rt_protos.d/${pkgname}.conf" "${pkgdir}/etc/iproute2/rt_protos.d/${pkgname}.conf"
+ install -Dm0644 "${pkgname}/${pkgname}.conf" "${pkgdir}/etc/${pkgname}/${pkgname}.conf"
+ install -Dm0644 "${pkgname}/vtysh.conf" "${pkgdir}/etc/${pkgname}/vtysh.conf"
+ install -Dm0644 "rsyslog.d/45-${pkgname}.conf" "${pkgdir}/etc/rsyslog.d/45-${pkgname}.conf"
+ popd
+
chown -R 177:177 "${pkgdir}/etc/frr"
}