summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8679214c112a..7319f00126ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsleyes-widgets
-pkgver=0.12.3
+pkgver=0.14.4
pkgrel=1
pkgdesc="FSLeyes is the FSL image viewer, widgets is one of its dependent projects"
arch=('any')
@@ -8,15 +8,20 @@ url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
license=('Apache')
groups=()
depends=('python')
-makedepends=('python-six' 'python-numpy' 'python-matplotlib' 'python-wxpython>=4.0.1-2' 'python-deprecation')
+makedepends=('python-six' 'python-numpy' 'python-matplotlib' 'python-wxpython' 'python-deprecation')
optdepends=()
provides=()
conflicts=()
replaces=()
source=("https://git.fmrib.ox.ac.uk/fsl/fsleyes/${pkgname#fsleyes-}/-/archive/${pkgver}/${pkgname#fsleyes-}-${pkgver}.tar.gz")
-sha256sums=('76756235969f9f4b44882b9440a9de2821c74de96b20bbcb11419669344464da')
+sha256sums=('7a624f54bb958c9654d469c1b390c738235551a9a46be334dfad759362cf9b71')
+
+build() {
+ cd "$srcdir/${pkgname#fsleyes-}-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
cd "$srcdir/${pkgname#fsleyes-}-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*whl
}