summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83d3bdcd1c61..6cae6ce6ab1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsleyes-widgets
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="FSLeyes is the FSL image viewer, widgets is one of its dependent projects"
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
@@ -20,5 +20,7 @@ package() {
cd "$srcdir/${pkgname#fsleyes-}-$pkgver-"*
# "Patching" for deprecation 2.x support
sed -i 's/deprecation>=1\.\*,<=2\.\*/deprecation>=1\.\*/g' requirements.txt
+ # "Patching" for matplotlib>3 support
+ sed -i 's/matplotlib>=1\.5,<3/matplotlib>=1\.5/g' requirements.txt
python setup.py install --root="$pkgdir/" --optimize=1
}