summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3b7d42b71b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
+pkgname=fsleyes-widgets
+pkgver=0.0.6
+pkgrel=1
+pkgdesc="FSLeyes is the FSL image viewer, widgets is one of its dependent projects"
+arch=('any')
+url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
+license=('Apache')
+groups=()
+depends=('python')
+makedepends=('python-six' 'python-numpy' 'python-matplotlib' 'wxpython-phoenix')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+source=($pkgname-$pkgver.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/widgets/repository/archive.tar.gz?ref=$pkgver)
+sha256sums=('a040846a4f968a82f09578c05877ecc752fe10a7fed4af94515170fae1f13082')
+
+package() {
+ cd "$srcdir/${pkgname#fsleyes-}-$pkgver-"*
+ python setup.py install --root="$pkgdir/" --optimize=1
+}