summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15c7ac1579e4..dc21d48f6553 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
# Maintainer: Javier Tiá <javier dot tia at gmail dot com>
+# Contributor: András Wacha <wacha dot andras at ttk dot mta dot hu>
pkgname=fsniper
pkgver=1.3.1
-pkgrel=2
+pkgrel=3
pkgdesc='Daemon to run scripts based on changes in files monitored by inotify'
url='http://projects.l3ib.org/fsniper/'
license=('GPL3')
depends=('pcre' 'file')
makedepends=('autoconf' 'automake' 'libtool' 'gcc')
-source=("http://projects.l3ib.org/fsniper/files/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('e65a34221fc05eb7ececcd2fb783e3418de032f89082e09be3a8f75f6b056e6b')
+source=("http://projects.l3ib.org/fsniper/files/${pkgname}-${pkgver}.tar.gz"
+ "wait3_argument.patch")
+sha256sums=('e65a34221fc05eb7ececcd2fb783e3418de032f89082e09be3a8f75f6b056e6b'
+ '60e8390538728b463845c595cb035529fbaaa311a54b6a12eaee2c53688de55d')
arch=('i686' 'x86_64')
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p1 <${srcdir}/wait3_argument.patch
+}
+
build() {
cd ${srcdir}/${pkgname}-${pkgver}