summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9bd3efea6949..60fe42e27d4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=fsolauncher
_pkgname="FreeSO Launcher"
-pkgver=1.10.4_prod.2
-_electronversion=22
+pkgver=1.11.0_prod.1
+_electronversion=29
_nodeversion=16
pkgrel=1
pkgdesc="Official FreeSO Launcher made with Electron"
@@ -29,7 +29,7 @@ source=(
"${pkgname}.git::git+${_ghurl}.git#tag=${pkgver//_/-}"
"${pkgname}.sh"
)
-sha256sums=('c6378f82e2f3c274eb4173fc84eb4995e4745605f2c61ceb791f71407b0562aa'
+sha256sums=('fd70fcbcc261f3931d0d27578f68d18b02bfd7e4cf1e7a7b60019f4abf1b2f0d'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
_ensure_local_nvm() {
export NVM_DIR="${srcdir}/.nvm"
@@ -55,9 +55,9 @@ build() {
export npm_config_disturl=https://electronjs.org/headers
HOME="${srcdir}/.electron-gyp"
if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
- echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
- echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
- echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
+ export npm_config_registry=https://registry.npmmirror.com
+ export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
+ export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
else
echo "Your network is OK."
fi