summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 202eb641e3cb..08099d5eb501 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=fstar
pkgver=0.9.7.0
_subver=-alpha1
-pkgrel=1
+pkgrel=2
pkgdesc='A Higher-Order Effectful Language Designed for Program Verification'
url='https://fstar-lang.org/'
license=('Apache')
@@ -12,8 +12,16 @@ depends=('z3-git')
makedepends=('ocaml>=4.03' 'ocaml-findlib' 'ocaml-num' 'ocaml-batteries' 'ocaml-stdint' 'zarith' 'ocaml-yojson' 'ocaml-fileutils' 'ocaml-pprint' 'ocaml-menhir' 'ulex-git' 'ocaml-migrate-parsetree' 'ocaml-ppx_deriving' 'ocaml-ppx_deriving_yojson' 'ocaml-process')
provides=('fstar')
conflicts=('fstar-bin' 'fstar-git')
-source=("https://github.com/FStarLang/FStar/archive/v$pkgver$_subver.zip")
-md5sums=('754ecb3d2f6c234c78537707a87e6db2')
+source=("https://github.com/FStarLang/FStar/archive/v$pkgver$_subver.zip"
+ fix-ocaml-4.08.patch)
+md5sums=('754ecb3d2f6c234c78537707a87e6db2'
+ '1bbf449622e26f6ea2d414b6d9866e52')
+
+prepare() {
+ cd "FStar-$pkgver$_subver"
+
+ patch -Np1 -i ../fix-ocaml-4.08.patch
+}
build() {
cd "FStar-$pkgver$_subver"