summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8c0e2b1baae..ac8ac633477c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: alphRomeo323 <alpharomeo323dev at protonmail dot com>
# Contributor: William Brown <glowinthedarkcia at horsefucker dot org>
pkgname=ftba
-pkgver=202208131844_e5790011d3_release
+pkgver=202209161632_2afab8f106_release
pkgrel=1
url="https://feed-the-beast.com/app"
-arch=(any)
+arch=(x86_64)
pkgdesc="Offers many different styles of Minecraft modpacks to the community."
source=("https://apps.modpacks.ch/FTBApp/release/${pkgver//_/-}/FTBA_linux_${pkgver//_/-}.deb"
"ftb-app.desktop")
-sha256sums=("52b771025d09e327a55b26a86570e6cdc3c8428cdd8b0c93a9659b7405d9349f"
+sha256sums=("8edd8a0b1809b89bf7b07da3ad418ce73c86ac74717f5f7f5b558549ff385443"
"2b50da4dc2811b175e5602e91dfe18e981cba3e2e80deccb8f12b59776d8c530")
license=("LGPL2.1")
-depends=("java-runtime=17" "avahi") # Crashes without libavahi-common.so.3
+depends=("java-runtime=17" "alsa-lib" "nss" "gtk3")
# FTBA will download Adoptium for Minecraft, although system Java can be used too.
optdepends=("java-runtime=11: For playing some version of Minecraft with system Java."
"java-runtime=8: For playing some version of Minecraft with system Java.")
@@ -32,6 +32,7 @@ package() {
# Do not install to /opt
mv opt/FTBA usr/lib/ftb-app
+ rmdir opt
chmod +x usr/lib/ftb-app/bin/ftb-app
mv usr/lib/ftb-app/FTBApp usr/lib/ftb-app/ftb-app
cp usr/lib/ftb-app/.install4j/FTBApp.png usr/share/icons/hicolor/512x512/apps/ftb-app.png