summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c05631b85b96..333f658ced64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: getzze <getzze at gmail dot com>
pkgname=funkwhale
-pkgver=0.18
+pkgver=0.19.0
pkgrel=1
pkgdesc="A self-hosted, modern free and open-source music server, heavily inspired by Grooveshark."
arch=(any)
@@ -19,8 +19,9 @@ depends=('ffmpeg' 'libjpeg' 'postgresql' 'python'
'python-django-allauth'
'python-psycopg2'
'python-pytz'
- 'python-redis'
'python-django-redis'
+ 'python-redis'
+ 'python-kombu'
'python-celery'
'python-django-cors-headers'
'python-musicbrainzngs'
@@ -29,17 +30,14 @@ depends=('ffmpeg' 'libjpeg' 'postgresql' 'python'
'python-pendulum'
'python-persisting-theory'
'python-django-versatile-imagefield'
- 'python-django-filter1.1'
+ 'python-django-filter'
'python-django-rest-auth'
- 'python-beautifulsoup4'
- 'python-markdown'
'python-mutagen'
'python-django-taggit'
'python-pymemoize'
'python-django-dynamic-preferences'
'python-raven'
'python-magic-git'
- 'python-ffmpeg'
'python-django-channels'
'python-django-channels-redis'
'python-daphne'
@@ -50,10 +48,17 @@ depends=('ffmpeg' 'libjpeg' 'postgresql' 'python'
'python-django-auth-ldap'
'python-service-identity'
'python-pydub'
+ 'python-pyld>=1.0.4'
+ 'python-aiohttp'
+ 'python-autobahn'
+ 'python-django-oauth-toolkit'
+ 'python-django-storages'
+ 'python-boto3'
+ 'python-unicode-slugify-git'
)
makedepends=(git)
-_source_api="https://code.eliotberriot.com/funkwhale/funkwhale/builds/artifacts/${pkgver}/download?job="
-_source_env="https://code.eliotberriot.com/funkwhale/funkwhale/raw/${pkgver}/deploy/"
+_source_api="https://dev.funkwhale.audio/funkwhale/funkwhale/-/jobs/artifacts/${pkgver}/download?job="
+_source_env="https://dev.funkwhale.audio/funkwhale/funkwhale/raw/${pkgver}/deploy/"
source=("${pkgname}-${pkgver}-api.zip::${_source_api}build_api"
"${pkgname}-${pkgver}-front.zip::${_source_api}build_front"
"${_source_env}funkwhale_proxy.conf"
@@ -65,14 +70,14 @@ source=("${pkgname}-${pkgver}-api.zip::${_source_api}build_api"
"env-template"
"funkwhale.service"
)
-sha256sums=('bd39230b27e22d1a41cd058979f67cc1727b5ea845ce32b29e8de99bf6d364f3'
- '20faddbf6a74722826eb889df4ebd4fc18810ff80d3741608b1d86d17e4f408a'
+sha256sums=('8838f83c1c658a758ef283d22f682820b4866f33d83d7832eb52fa04b4f729c8'
+ '2a664eb81f46c1f7c9d52d472a2a9958356eb409fed36bb2acba7bde87c7d7c6'
'2906a075b41dcd2375c601482cb5a00e42cb87c613012b176c570d77918afbf2'
'ee571b8a30b968849fcf5c7b2588f298a3046609fe9792dd0b59024899dfea3a'
'a964a7802252d20a3319e2131c27ec307ad4f454921c2db31971c080150d7c9b'
'0e6d7c96b7c1ec63794214decb1f2e7dd112a22b02e55555cf98c2a573014af6'
'4a28ddf6a6ba8ec28c10a164f82e3d5e5904d6dfe68ae8852428a589cee210c5'
- 'dcc7a76ff136db29a830f9228a88b2ab64639d44ef2d8db363315fe5828efec9'
+ 'ee895ecaf5faaa794f161e9df038177497cb5c49510acd3aef088f75eb8b02f1'
'c2ee8160e2f4f87a2d4fe46136ffb8ea14422dc599db3eca4341e48db26d72ad'
'01104122e3df765735b1062aa15e7a73c7949f2d9b7332c0e02e02db66345349')
install=${pkgname}.install