summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ae71ac5a602..0e77c820ae0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,34 @@
# Contributor: brikler
pkgname=fwts-git
-pkgver=4604.2b14ce46
+pkgver=21.02.00.r7.3ba26885
pkgrel=1
pkgdesc="The FirmWare Test Suite is a tool to do automatic testing of a PC's firmware"
arch=('i686' 'x86_64')
url="http://smackerelofopinion.blogspot.com/2010/08/firmware-test-suite-biosacpi-health.html"
license=('GPL')
-depends=('pcre' 'json-c')
+depends=('dtc' 'libbsd' 'pcre' 'json-c')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
makedepends=('git')
-source=('fwts::git://kernel.ubuntu.com/hwe/fwts.git')
+source=("${pkgname}::git://kernel.ubuntu.com/hwe/fwts.git")
build() {
- cd fwts
- autoreconf -ivf
- CPPFLAGS="$CPPFLAGS -O2"
- CFLAGS=--sysroot= ./configure --prefix=/usr
- make
+ cd "${srcdir}/${pkgname}"
+ autoreconf -ivf
+ CPPFLAGS="$CPPFLAGS -O2"
+ CFLAGS=--sysroot= ./configure --prefix=/usr
+ make
}
package() {
- cd fwts
- make DESTDIR=$pkgdir install
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
}
pkgver() {
- cd fwts
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd "${srcdir}/${pkgname}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g' | sed 's/V//')"
}
md5sums=('SKIP')