summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 26 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7456303d21d0..376beb1a39c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,49 @@
# Maintainer : Daniel Bermond < gmail-com: danielbermond >
-# NOTE:
-# This is a header-only library. No dependecy is needed and no build is necessary.
-# If you want to build the checks/tests, uncomment the blocks in checkdepends, build() and check().
-
pkgname=fxdiv-git
-pkgver=r51.811b482
-pkgrel=2
+_srcname=FXdiv
+pkgver=r53.f8c5354
+pkgrel=1
pkgdesc='Header-only library for division via fixed-point multiplication by inverse (git version)'
arch=('any')
url='https://github.com/Maratyszcza/FXdiv/'
license=('MIT')
makedepends=('git')
-#checkdepends=(
-# official repositories:
-# 'python2' 'ninja'
-# AUR:
-# 'confu2-git'
-#)
+checkdepends=(
+ # official repositories:
+ 'python2' 'ninja'
+ # AUR:
+ 'confu2-git'
+)
provides=('fxdiv')
conflicts=('fxdiv')
-source=("$pkgname"::'git+https://github.com/Maratyszcza/FXdiv.git')
+source=('git+https://github.com/Maratyszcza/FXdiv.git')
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, no tags available
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-# uncomment this block to build and run the checks/tests
-#build() {
-# cd "$pkgname"
-# confu2 setup
-# python2 ./configure.py
-# ninja
-#}
-#
-#check() {
-# cd "${pkgname}/bin"
-# local _test
-# for _test in *
-# do
-# printf '%s\n' " -> Running test '${_test}'..."
-# ./"$_test"
-# done
-#}
+check() {
+ cd "$_srcname"
+ confu2 setup
+ python2 ./configure.py
+ ninja
+
+ cd bin
+ local _test
+ for _test in *
+ do
+ printf '%s\n' " -> Running test '${_test}'..."
+ ./"$_test"
+ done
+}
package() {
- cd "${pkgname}"
+ cd "$_srcname"
# headers
mkdir -p "${pkgdir}/usr/include"