summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73a99bd7b0aa..29d2cf13f3d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
-# Maintainer: Daniel Menelkir <menelkir at itroll dot org>
+# Maintainer: Daniel Menelkir <dmenelkir at gmail dot com>
# Contributor: Evgeniy Alekseev <arcanis.arch at gmail dot com>
# Contributor: Valeriy Lyasotskiy <onestep@ukr.net>
pkgname=g15daemon
-pkgver=3.0.1
+pkgver=3.0.4
pkgrel=1
pkgdesc="A daemon that makes it possible to use the G-Buttons and draw on the G15 LCD"
arch=('x86_64')
url="https://gitlab.com/menelkir/g15daemon"
license=('GPL')
depends=('libg15render>=3.0')
+conflicts=('g15daemon-git')
source=(https://gitlab.com/menelkir/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.bz2)
-sha512sums=('07dd9cdb57065620cf5c27177154a3d8efac359e52c36de0259ba12ae4633b7c900165feb8d21bd2b1a169201e6feb7889d8c9282621a66070789ba8b4f4f0ac')
+sha512sums=('4adbb11ca8128bbaff5ad1dee17ddcfcdfca589f7e8a1a264127dd9d5aec39e07e4986a4b78f4199fb7f3e12979fd8d50a851b047b6cb8cfa13410aa59df062a')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
- ./configure --prefix=/usr --sbindir=/usr/bin --disable-static
+ ./configure --prefix=/usr --sbindir=/usr/bin
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/contrib/init/g15daemon.service" \
- "${pkgdir}/usr/lib/systemd/system/g15daemon.service"
+ echo ""
+ echo "This package doesn't come with an init, you should install one:"
+ echo "g15daemon-runit"
+ echo "g15daemon-openrc"
+ echo "g15daemon-systemd"
}