summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 942473c1f6d0..dd3efa3a14f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
pkgname=gallery-dl
pkgver=1.17.1
-pkgrel=1
+pkgrel=2
pkgdesc='Command-line program to download image-galleries and collections from several image hosting sites'
arch=(any)
url=https://github.com/mikf/gallery-dl
license=(GPL2)
depends=(python python-requests)
makedepends=(python-setuptools git)
+checkdepends=(python-nose)
optdepends=('ffmpeg: Convert Pixiv Ugoira to WebM'
'youtube-dl: Download videos'
'python-pysocks: SOCKS support')
@@ -23,6 +24,10 @@ build() {
python setup.py build
}
+check() {
+ make -C ${pkgname} test
+}
+
package() {
cd ${pkgname}
python setup.py install --root="$pkgdir" --optimize=1 --skip-build