summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0327ad219b97..32f53d8643a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=gam
pkgver=3.51
-pkgrel=1
+pkgrel=2
holdver=$pkgver
-pkgdesc="Command line tool for Google Apps Administrators to manage domain and user settings"
+pkgdesc="Command line tool for Google Apps Administrators to manage domain and user settings; patched for managed installation"
arch=('any')
url="http://code.google.com/p/google-apps-manager/"
license=('Apache')
@@ -12,14 +12,19 @@ depends=('python2')
makedepends=('tar gzip')
optdepends=()
provides=()
-source=("https://github.com/jay0lee/GAM/archive/v${pkgver}.tar.gz")
+source=("https://github.com/jay0lee/GAM/archive/v${pkgver}.tar.gz"
+ "client_secrets.patch")
noextract=("v${pkgver}.tar.gz")
-md5sums=('0ab658cb70b375a4634d477edcd02123')
+md5sums=('0ab658cb70b375a4634d477edcd02123'
+ 'b9f182cf06a9a058c7866a6930aeb755')
build() {
cd $srcdir
- mkdir build
+ [[ -d $srcdir/build ]] && rm -rf $srcdir/build
+ mkdir build
tar --gzip --extract --overwrite --strip-components=1 --directory=build --file=v${pkgver}.tar.gz
+ cd build
+ patch -uN -i ../client_secrets.patch || return 1
}
package() {