summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4b287e247a9..4ccd4298ded0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gamehub
_pkgver=0.16.3-2
pkgver=${_pkgver//-/.}
-pkgrel=1
+pkgrel=2
pkgdesc="Games manager, downloader, library that supports GOG, Steam and Humble Bundle"
arch=(i686 x86_64 armv6h armv7h aarch64)
url="https://tkashkin.github.io/projects/gamehub/"
@@ -16,8 +16,15 @@ depends=(gtk3 glib2 libgee libsoup json-glib sqlite webkit2gtk libmanette libxts
makedepends=(git meson ninja vala)
options=(!strip debug)
#source=("git+https://github.com/tkashkin/GameHub/archive/${_pkgver}-master.tar.gz")
-source=("git+https://github.com/tkashkin/GameHub.git#tag=${_pkgver}-master")
-sha256sums=('SKIP')
+source=("git+https://github.com/tkashkin/GameHub.git#tag=${_pkgver}-master"
+ "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/gamehub-protonfix.patch")
+sha256sums=('SKIP'
+ '26e267dade0b416699707a8612aa4f1c32b60a08889c217127ddf1843b7302ba')
+
+prepare() {
+ cd "GameHub"
+ patch -Np1 -i ../gamehub-protonfix.patch
+}
build() {
cd "GameHub"