summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8ce4554e082..de975ef1c648 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: Ysblokje <ysblokje at gmail dot com>
pkgname=('gamemode')
pkgver=1.0
-pkgrel=2
-pkgdesc="GameMode is a daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS."
+pkgrel=3
+pkgdesc="A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS."
arch=('x86_64')
url="https://github.com/FeralInteractive/gamemode.git"
license=('BSD 3-Clause License (Revised)')
-depends=('systemd' 'polkit')
+optdepends=('systemd')
+depends=('polkit')
makedepends=('meson' 'ninja' 'pkg-config')
provides=('gamemode')
source=("https://github.com/FeralInteractive/gamemode/archive/$pkgver.tar.gz")
sha256sums=('bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d')
build() {
- cd gamemode-$pkgver
- meson --prefix=/usr build -Dwithsystemd-user-unit-dir=/etc/systemd/user
- cd build
- ninja
+ arch-meson gamemode-$pkgver build -Dwith-systemd-user-unit-dir=/etc/systemd/user
+ ninja -C build
}
package() {
- cd gamemode-$pkgver/build
- DESTDIR=$pkgdir ninja install
+ DESTDIR=$pkgdir ninja -C build install
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" ${pkgname}-${pkgver}/LICENSE.txt
}