summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD97
1 files changed, 97 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1010aed66482
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,97 @@
+
+_pkgname=gamescope
+pkgname=${_pkgname}-sk-git
+pkgver=3.14.1.r14.gc3c54be
+pkgrel=1
+pkgdesc='SteamOS session compositing window manager'
+arch=(x86_64)
+url=https://github.com/ValveSoftware/gamescope
+license=(BSD)
+depends=(
+ gcc-libs
+ glibc
+ glm
+ hwdata
+ libavif
+ libcap.so
+ libdisplay-info.so
+ libdrm
+ libliftoff.so
+ libinput
+ libpipewire-0.3.so
+ libvulkan.so
+ libx11
+ libxcb
+ libxcomposite
+ libxdamage
+ libxext
+ libxfixes
+ libxkbcommon
+ libxmu
+ libxrender
+ libxres
+ libxtst
+ libxxf86vm
+ seatd
+ sdl2
+ vulkan-icd-loader
+ wayland
+ xcb-util-wm
+ xcb-util-errors
+ xorg-server-xwayland
+)
+makedepends=(
+ benchmark
+ cmake
+ git
+ glslang
+ meson
+ ninja
+ vulkan-headers
+ wayland-protocols
+)
+_branch=sk-gamscope
+source=("git+https://github.com/3003n/gamescope.git#bransh=${_branch}")
+b2sums=('SKIP')
+
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+prepare() {
+ cd $_pkgname
+ # This really should be a pacman feature...
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ git apply "../$src"
+ done
+ meson subprojects download
+ git submodule init
+ git -c protocol.file.allow=always submodule update
+
+ # Use Arch provided libdisplay-info, do use other subprojects as is
+ rm -rf subprojects/libdisplay-info
+}
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson "${_pkgname}" build \
+ -Dforce_fallback_for=stb \
+ -Dpipewire=enabled
+ meson compile -C build
+}
+
+package() {
+ meson install -C build --skip-subprojects --destdir="${pkgdir}"
+
+ cd "$srcdir/$_pkgname"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname/"
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file