summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6adb45167629..f3bd3b31c62e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Peter Reschenhofer < peterreschenhofer at gmail dot com >
# Maintainer: gaelic < gaelic at luchmhor dot net>
+# Maintainer: Peter Reschenhofer < peterreschenhofer at gmail dot com >
pkgname=gams
-pkgver=26.1.0
+pkgver=27.1.0
pkgrel=1
pkgdesc="The General Algebraic Modeling System (GAMS) is a high-level modeling system for mathematical optimization."
arch=('x86_64')
@@ -9,13 +9,18 @@ license=('custom')
url="http://www.gams.com/"
depends=()
conflicts=()
+options=('!strip')
-source=("https://d37drm4t2jghv5.cloudfront.net/distributions/${pkgver}/linux/linux_x64_64_sfx.exe")
+source=("https://d37drm4t2jghv5.cloudfront.net/distributions/${pkgver}/linux/linux_x64_64_sfx.exe"
+ "gams-studio.desktop")
-sha256sums=("1eb8d551ce3489cb10e062566f9b3da7e1e98079d75c692540ff41101c7c024c")
+sha256sums=("bf51c6c1a35a7376b5ec1f568584b2d66e9c95581bd25f32d7774716df94a5b1"
+ "5349929ad07ea8de5e6f1e5d03f264b2fd5afc161b4204981d30fc2ff8faed7e")
package() {
install -d ${pkgdir}/{opt/gams,usr/bin}
cp -r ${srcdir}/gams*_linux_x64_64_sfx/* ${pkgdir}/opt/gams/
+ install -Dm644 gams-studio.desktop ${pkgdir}/usr/share/applications/gams-studio.desktop
ln -s "/opt/gams/gams" "$pkgdir/usr/bin/gams"
+ ln -s "/opt/gams/studio/studio.AppImage" "$pkgdir/usr/bin/gams-studio"
}