summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cd96de86d54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=gaphor-git
+_pkgname=gaphor
+pkgver=0.28.7
+pkgrel=1
+pkgdesc='Gaphor is a UML and SysML modeling application written in Python'
+arch=('any')
+url=https://github.com/gaphor/gaphor
+license=('Apache')
+depends=('python-cairo' 'python-gaphas' 'python-generic' 'python-gobject' 'python-importlib-metadata' 'python-typing_extensions' 'python-tinycss2')
+makedepends=('python-pip' 'python-poetry')
+provides=('gaphor')
+conflicts=('gaphor')
+source=("git+https://github.com/gaphor/gaphor.git")
+b2sums=('SKIP')
+
+prepare() {
+ cd ${_pkgname}
+ # Avoid installing files directly under site-packages/
+ sed -i '/include = \["README.md"\]/d' pyproject.toml
+}
+
+build() {
+ cd ${_pkgname}
+ poetry build --format wheel
+}
+
+package() {
+ cd ${_pkgname}
+ export PYTHONHASHSEED=0
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps dist/*.whl
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/${_pkgname} LICENSE.txt
+}