summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 14 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c952fe8c0ea4..98c1336522c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,30 @@
# Contributor: Vladimir Ermakov <vooon341@gmail.com>
pkgname=gazebo
-pkgver=4.0.0
-pkgrel=3
+pkgver=5.0.1
+pkgrel=2
pkgdesc="A multi-robot simulator for outdoor environments"
arch=('i686' 'x86_64')
url="http://gazebosim.org/"
license=('Apache')
-# See: http://www.gazebosim.org/user_guide/installation__requirements.html
+# See: http://www.gazebosim.org/tutorials?tut=install_from_source&cat=install
depends=('boost>=1.40.0' 'curl>=4.0' 'freeglut' 'freeimage>=3.0'
'intel-tbb>=3.0' 'libccd>=1.4' 'libltdl>=2.4.2' 'libtar>=1.2' 'libxml2>=2.7.7'
- 'ogre-1.8' 'protobuf>=2.3.0' 'qt4' 'sdformat>=2.0.1'
+ 'ogre' 'protobuf>=2.3.0' 'qt4' 'sdformat>=2.0.1'
'tinyxml>=2.6.2')
optdepends=('bullet>=2.82: Bullet support'
- 'simbody>=3.3: simbody support'
- 'libdart>=3.0: dart support'
- 'cegui-0.7>=0.7.5: Design custom graphical interfaces'
+ 'cegui>=0.8.3: Design custom graphical interfaces'
'ffmpeg>=0.8.3: Playback movies on textured surfaces'
- 'urdfdom: Load URDF files'
- 'gdal: digital elevation terrains support')
+ 'gdal: Digital elevation terrains support'
+ 'libdart>=3.0: DART support'
+ 'libusb: USB peripherals support'
+ 'ruby-ronn: Generate manpages'
+ 'simbody>=3.3: Simbody support'
+ 'urdfdom: Load URDF files')
makedepends=('cmake' 'doxygen' 'pkg-config>=0.26')
install="${pkgname}.install"
source=(http://osrf-distributions.s3.amazonaws.com/gazebo/releases/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('65a3599321f76006518dafb1630b5b40')
-provides=('gazebo')
-conflicts=('gazebo')
+sha256sums=('81773edbf709359f4191ff33b6b2e6adf395a88806022c8cfa964963e5c7099b')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -37,13 +37,11 @@ build() {
# Create build directory
mkdir -p build && cd build
- # Adapt paths for Ogre 1.8
- export PKG_CONFIG_PATH="/opt/OGRE-1.8/lib/pkgconfig:$PKG_CONFIG_PATH"
-
# Run CMake
# Note: we skip unit tests (else set to TRUE)
cmake .. -DCMAKE_BUILD_TYPE="Release" \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
-DENABLE_TESTS_COMPILATION:BOOL=False
# Compile Gazebo
@@ -55,10 +53,6 @@ package() {
# Install Gazebo
make DESTDIR="${pkgdir}" install
-
- # Add paths for OGRE-1.8
- echo "export LD_LIBRARY_PATH=\$LD_LIBRARY_PATH:/opt/OGRE-1.8/lib" >> ${pkgdir}/usr/share/gazebo/setup.sh
- echo "export LD_LIBRARY_PATH=\$LD_LIBRARY_PATH:/opt/OGRE-1.8/lib" >> ${pkgdir}/usr/share/gazebo-4.0/setup.sh
}
# vim:set ts=2 sw=2 et: