summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 18 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb99494bf09c..20a84a987fb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gazebo
pkgver=5.0.1
-pkgrel=3
+pkgrel=4
pkgdesc="A multi-robot simulator for outdoor environments"
arch=('i686' 'x86_64')
url="http://gazebosim.org/"
@@ -25,26 +25,41 @@ optdepends=('bullet>=2.82: Bullet support'
'urdfdom: Load URDF files')
makedepends=('cmake' 'doxygen' 'pkg-config>=0.26')
install="${pkgname}.install"
-source=(http://osrf-distributions.s3.amazonaws.com/gazebo/releases/${pkgname}-${pkgver}.tar.bz2)
-sha256sums=('81773edbf709359f4191ff33b6b2e6adf395a88806022c8cfa964963e5c7099b')
+source=("http://osrf-distributions.s3.amazonaws.com/gazebo/releases/${pkgname}-${pkgver}.tar.bz2"
+ "boost1.58.patch"
+ "bullet2.83.patch")
+sha256sums=('81773edbf709359f4191ff33b6b2e6adf395a88806022c8cfa964963e5c7099b'
+ 'e4bf17b4e0fbe3094a17af108e4e08627b169890b365737b42a80456c17d7bad'
+ '7e82c241e1179348e9040bdf87232fb655c492597d4efcb87a6c886a77fa0567')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
# Fix gdal includes
+ msg "Applying gdal includes fix..."
find . -type f -exec sed -i 's|include <gdal/|include <|g' {} \;
+ # Apply Boost 1.58 patch (fixed upstream)
+ msg "Applying Boost 1.58 patch..."
+ patch -p1 < ${srcdir}/boost1.58.patch
+
+ # Apply Bullet 2.83 patch (fixed upstream)
+ msg "Applying Bullet 2.83 patch..."
+ patch -p1 < ${srcdir}/bullet2.83.patch
+
# Create build directory
mkdir -p build && cd build
# Run CMake
# Note: we skip unit tests (else set to TRUE)
+ msg "Preparing Makefiles..."
cmake .. -DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DENABLE_TESTS_COMPILATION:BOOL=False
# Compile Gazebo
+ msg "Compiling..."
make
}